
 

 

 

 

 

 

 

 

 

 

 

 

Creating Interactive Procedures and 
Training Courses 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

© 2017 ParallelGraphics 



 

 

CONTENTS 

 

INTRODUCTION ........................................................................................................... 1 
1 PROCESS LAYOUT AND BASIC OPERATIONS ............................................... 1 
1.1 General Data Flow Diagram ................................................................................ 2 
1.2 Preparing Input Data for RapidAuthor Project ...................................................... 3 
1.3 Creating RapidAuthor Project .............................................................................. 3 

2 EDITING RAPIDAUTHOR PROJECT .................................................................. 6 
2.1 Opening RapidAuthor Project .............................................................................. 6 
2.2 Selecting Items .................................................................................................... 6 

2.2.1 Selecting Items in Item Tree or Item List ....................................................... 6 
2.2.2 Selecting Items in 3D View Window .............................................................. 7 

2.3 Editing Items ....................................................................................................... 8 
2.3.1 Choosing Representations ............................................................................ 8 
2.3.2 Deleting, Re-Ordering and Moving Items ...................................................... 9 
2.3.3 Setting Items as Background ........................................................................ 9 

2.4 Enhancing 3D Model ......................................................................................... 10 
2.5 Creating 3D Procedure ...................................................................................... 10 
2.6 Editing 3D Procedure ........................................................................................ 10 

2.6.1 Creating Actions ......................................................................................... 11 
2.6.2 Editing Actions ............................................................................................ 11 
2.6.3 Using Collections in Animations .................................................................. 12 
2.6.4 Creating Action Unions with Explosion Wizard ............................................ 12 

2.7 Creating 2D Images .......................................................................................... 13 
2.8 Creating and Editing Document ......................................................................... 15 

2.8.1 Creating Document ..................................................................................... 15 
2.8.2 Editing Document ....................................................................................... 15 

2.9 Basics of Creating Training (RapidLearning Only) ............................................. 16 
2.9.1 Generating Training Scenario from 3D Procedure ...................................... 16 
2.9.2 Creating Training Scenario from Scratch .................................................... 16 
2.9.3 Creating Animations ................................................................................... 17 
2.9.4 Using Scenario Elements ............................................................................ 17 

2.10 Publishing Training or Procedure Publications ................................................ 18 
3 WORKING WITH SPECIFICATION COMPONENTS ......................................... 19 
3.1 Specifications: Overview ................................................................................... 19 
3.2 Changing Specifications .................................................................................... 20 
3.3 Adding Specifications ........................................................................................ 21 

4 USEFUL ADDITIONAL OPERATIONS .............................................................. 22 
4.1 Adding Data to Existing Project ......................................................................... 22 
4.2 Additional Optimization of Existing Project ........................................................ 23 
4.3 Exchanging Projects between Authors .............................................................. 27 
4.4 Recommendations on Increasing Publication Performance ............................... 28 

4.4.1 Estimating Publication Performance ........................................................... 28 
4.4.2 Optimizing 3D Data ..................................................................................... 28 

 

 



Introduction  

 1 

Introduction 

This document gives practical recommendations on how to create the procedure and training publications 
using the RapidAuthor tools. 

The procedure publication is a documentary unit that usually contains a descriptive text of the technical 
procedure with 2D and/or 3D visualization of the procedure. The training publication is a documentary unit 
that usually contains the multi-mode training tasks with 2D and/or 3D visualization. 

The procedure publication can be used standalone or integrated into existing Product Lifecycle Management 
(PLM), Interactive Electronic Technical Manual (IETM) or Customer Relationship Management (CRM) 
systems. 

The training publication can also be used standalone or integrated into Learning Management System (LMS).  

The following RapidAuthor tools are used to create the procedure and training publications: 

RapidManual is a powerful authoring application for building interactive audio-visual procedure publications 
for technical support, maintenance and operations.  

RapidLearning is an expanded version of RapidManual. In addition to the RapidManual functionality, 
RapidLearning is used to create training publications that combine procedures with training materials.  

RapidManual and RapidLearning use a set of customizable components (specification components) for 
authoring the procedure and training publications in accordance with various information standards (for 
example, S1000D Issue 4.1, DITA 1.1, ATA 2200 AMM). 

RapidGenerator is an application that is used to preprocess and import data exported from CAD/PLM 
systems. The preprocessed 3D models are used in RapidManual, RapidLearning and RapidCatalog.  To 
import 3D data, RapidGenerator uses a set of customizable components (plug-ins) designed for different 
CAD systems. A customer-specific plug-in can be developed by ParallelGraphics on demand. This tailored 
plug-in can import the customer’s source data (including PDM data) in the most effective way.  

RapidAdministrator is a helper application that provides the advanced abilities to manage projects and 
working spaces for RapidAuthor.  

1 Process Layout and Basic Operations 

To create the procedure and training publications, the author should perform the following basic steps: 

1. Preparing input data for the RapidAuthor project.  

3D data is obtained from CAD systems. 

2. Creating the RapidAuthor project. 

RapidAdministrator is used for creating a working space for the projects. 

RapidGenerator is used for creating a new project and for importing the data into the project. 

3. Editing the RapidAuthor project.  

RapidManual and RapidLearning are used for editing the project. 

4. Publishing the procedure and training publications. 

http://www.multitran.ru/c/m.exe?t=5674012_1_2&ifp=1&s1=Customer%20Relationship%20Management
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 RapidManual and RapidLearning are used for publishing the procedure and training publications. 

Pay attention that RapidGenerator is also available in the RapidManual and RapidLearning environment. To 
open RapidGenerator within RapidManual or RapidLearning, from the File menu, choose Import Data. 

1.1 General Data Flow Diagram 

The general data flow diagram for creating the procedure and training publications is shown in Fig. 1. 
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Fig.1. Data flow diagram of creating the procedure and training publications 

 Box – an application; parallelogram – data. Dimmed parallelograms – input and output data used in the 
development process. 
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1.2 Preparing Input Data for RapidAuthor Project 

The following set of input data is required for creating the RapidAuthor project: 

1. 3D data from CAD. 

2. Additional procedure document can be used for automatic generation of procedure and training 
scenario templates, for example S1000D procedural data modules. 

1.3 Creating RapidAuthor Project 

The RapidAuthor project can be created using the following basic steps: 

1. Creating a working space.  

2. Creating an empty project. 

3. Adding data to the project. 

RapidAdministrator should be used to create a working space. To start RapidAdministrator, choose Start > All 
Programs > Cortona3D > RapidAdministrator. 

RapidGenerator is used to create an empty project and to add data to the project. To start RapidGenerator, 
choose Start > All Programs > Cortona3D > RapidGenerator. 

The RapidAuthor project stores 3D models and other related data such as images, metadata and technical 

documents. A working space is a specially organized set of working folders that contain RapidAuthor 

projects. The working space has a descriptive name. In the working space the author creates a new project 

and fills the project with the input data.  

Procedure 

1. To create a working space: 

 Start RapidAdministrator. 

 Click All Configurations, and then click Create.  

 In the Working space properties area that appears, type in the working space name, description 
(optionally), and author (optionally).  

 In the Base path, specify the location where you want to locate the folders of the working space. You 

can also click the button   to specify the existing folder.  

 Click Apply.  
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See the RapidAdministrator help system for more information about managing the working folders. 

2. To create a new project: 

 Start RapidGenerator. 

 From the Tools menu, choose Select Working Space.                                                                              
In the Select Working Space dialog box, choose the desired working space, and then click OK. 

 On the File menu, click New Project.                                                                                                              
The New Project dialog box appears. 

 In the Project Name box, type the descriptive name for the project. Make sure that the dialog box 
shows the proper working space for the new project, and then click OK. This creates a new empty 
project (that is a project without any geometric data) in the current working space.   

 

3. To import data to the project: 

 Start RapidGenerator. 

 Choose the RapidDataImportTool plug-in by clicking its name in the in the Plug-in name box.  

 To choose the required import profile, click Settings. The Choose Profile dialog box appears. 

 In the Choose Profile dialog box, click the name of the required profile. For more information about the 
current dialog box, click the Help button.  
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 To start importing the data, click Start. 

 In the dialog box that appears, select the supported geometry file to be imported, and then click Open. 

NOTE: The options available in the dialog box depend on the chosen profile. In general, the dialog box 
allows you to select 3D data and additional PDM data (optionally). 

 The time required for the import procedure depends on the amount of input data. RapidGenerator 
saves the project when the import is finished.  If no default import setting are used, be sure to save the 
project when the import is finished (File menu > Save). 
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2 Editing RapidAuthor Project 

The RapidAuthor project can be edited using RapidManual or RapidLearning. To start RapidManual or 
RapidLearning, choose Start > Programs > Cortona3D > RapidManual or RapidLearning. 

NOTE: When RapidManual or RapidLearning are started on virtual machine for the first time, it could be 
required to change the renderer for proper display of 3D model. To change the renderer, click Tools > 
Options > 3D View > Renderer. 

The following basic steps are used for editing the RapidAuthor project: 

2.1 Opening RapidAuthor Project  

Once the RapidAuthor project has been created using RapidGenerator, it can be opened in RapidManual or 
RapidLearning. 

Procedure 

To open the project: 

 On the File menu, click Open Project. In the upper section of the Open Project dialog box, choose 
the same working space that was specified in RapidGenerator for the project, then in the lower section 
click the project to be opened, choose the language and click Open. 

NOTE: If the name of specification component is not specified for the project, the Select Specification 
dialog box appears. This allows choosing a specification component for the project.  

 When 3D data is imported into a project, it is initially hidden in the 3D View window. To display the 
hidden Items, select them in the Item Tree and make Items visible by using the Show Solid command 
(3D View > Hide/Show Selection > Show Solid). 

 Use the Save Project command from the File menu to save your work. 

2.2 Selecting Items  

Once you have got some Items in the 3D View window, you can start putting them where you want them, 
choosing their level of detail and material, and changing their position in the tree hierarchy. All manipulations 
with Items can be done by applying commands to the selected Items. There are several techniques for 
selecting Items using different selection modes described below. 

2.2.1 Selecting Items in Item Tree or Item List 

Procedure 

To select Item(s) in the Item Tree or Item List windows: 

 Click the Item name or icon. The name of the selected Item is highlighted.  

 To select multiple Items, click the Items one by one with the CTRL key pressed.  

 To select a group of Items that are next to each other, click the first Item, and then click the last Item 
with the SHIFT key pressed.  



Editing RapidAuthor Project  

 7 

 To select Items by a selection rectangle drawn in the Item Tree window, click somewhere in the 
window and drag to pull out a selection rectangle. Continue dragging until the rectangle encloses all 
required Items.  

2.2.2 Selecting Items in 3D View Window 

To select Items directly in the 3D View window, on the Selection menu, click Selection in 3D . 

There are two ways for selecting Items in the 3D View window: clicking Item in the 3D View window, or 
drawing a selection rectangle (the Frame Selection mode).  

These ways are used in the following selection modes: 

The Frame Selection Mode provides two selection options: Frame Crossing and Frame Bounding. 

  Frame Crossing selects those Items that have at least one face inside the selection rectangle 
drawn in the 3D View window. 

  Frame Bounding selects those Items that have all faces inside the selection rectangle drawn in the 
3D View window.  

The  Assembly Selection in 3D mode allows the parent assembly of Item to be selected in the 3D View 
window. To enable the mode, on the Selection menu, click Assembly Selection in 3D. 

The  Step-by-Step Selection in 3D mode allows the parent Item to be selected by clicking its child Item 
in the 3D View window. Clicking successively the child Items navigates up the Item Tree hierarchy until the 
last parent Item of the hierarchy is achieved. When the last parent Item of the hierarchy is achieved, the 
selection returns to the Item initially selected in the 3D View window. To enable the mode, on the Selection 
menu, click Step-by-Step Selection in 3D. 

When the SHIFT, CTRL, or ALT key is pressed simultaneously with selecting Items, 

CTRL – adds to the selection, 

ALT – subtracts from the selection, 

SHIFT – if in the Frame Selection mode, selects from the already selected.  

Procedure 

To select Item in the 3D View window: 

 Click the required Item in the 3D View window.                                                                                                                                                              
This highlights Item if the Highlight Selection button is pressed.  

To select multiple Items in the 3D View window: 

 Press and hold down CTRL, and then click each required Item in the 3D View window you want to 
select.  

To select Items by a selection rectangle:  

1. Choose one of the available selection options – Frame Crossing or Frame Bounding by choosing the 
corresponding command from the Selection menu.  

2. Click somewhere in the 3D View window and drag to pull out a selection rectangle. Continue dragging 
until the rectangle encloses all Items to be selected. Be sure to start dragging at a point that will enclose 
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the Items required within a rectangle drawn from that point. Release the mouse button. The Items that 
fall inside the selection rectangle appear highlighted.  

2.3 Editing Items  

After a 3D model has been imported into a project, it may need some modification to better suit the 
procedure. This includes deleting irrelevant Items, adding supplementary Items, moving Items, changing the 
Items hierarchy, changing the representation (level of detail) of items, and other operations. 

2.3.1 Choosing Representations 

RapidManual and RapidLearning enable two ways to choose representations for one Item or a group of 
Items: by name or by weight. The first method allows the author to choose the most suitable representation of 
the previously selected Items by specifying the name that was assigned to each Item during the step of data 
preparation in RapidGenerator. The second way uses the percentage parameter that is the number of 
triangles in the polygonal mesh. The first method is preferable for groups of Items since RapidGenerator uses 
robust simplification algorithms comprising a visual quality check.  

Procedure 

To choose representations by name: 

1. Select Item(s) for which you want to change the representation.  

2. Click Choose Representations by Name from the Edit menu or click Choose Representations by 
Name on the Standard toolbar.  

3. In the Choose Representation by Name dialog box, choose the name of representation, and then click 
OK. 

To choose representations by weight: 

1. Select Item(s) for which you want to change the representation. 

2. Click Choose Representations by Weight from the Edit menu. 

3. In the Choose Representation dialog box, specify the Weight parameter. The closer parameter to 0, the 
more simplified mesh of Item is selected from the list of different representations. Click OK. 

To edit the current representation properties for one or more Items: 

1. In the Item Tree window, select the Item(s), whose representation you want to edit.  

2. From the Edit menu, choose Change Representation Properties.  

The Edit Representation Properties dialog box appears.  

3. Set the required parameters and click OK.  

The changed representations are saved as a new representation for each selected Item and the 
representation becomes current for each selected Item. 
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2.3.2 Deleting, Re-Ordering and Moving Items 

Procedure 

To delete Items: 

1. Select the Item(s) to be deleted in the Item Tree or Item List or 3D View windows.  

2. On the Edit menu, click Delete.  

To see the deleted Item(s) in the Item Tree or Item List windows: 

 On the Edit menu, click Show Deleted Items. The deleted Item appears with its icon crossed . 

To restore deleted Item(s): 

1. Select the deleted Item(s) in the Item Tree or Item List windows.  

2. On the Edit menu, click Restore. 

To reorder Items within the tree hierarchy, do one of the following: 

 Right-click the Item in the Item Tree or Item List window, click Change Parent, and then click a new 
parent name.  

 Drag Item in the Item Tree to a new place. 

To move or rotate Items in the 3D View window: 

1. Select an Item you want to move or rotate.  

2. On the Edit menu, click Set Position.  

3. Specify translation and rotation with the manipulator and commands from the Edit Position dialog box.  

2.3.3 Setting Items as Background  

Items that represent the outer environment to the main items can be made semi-transparent for some 
actions. To do this, use the Set as Background command. 

Procedure 

To set Item(s) as background: 

1. Select Item(s) in the Item Tree or Item List or 3D View windows.  

2. On the Edit menu, click Set as Background.  

To restore the initial appearance of the background Item(s): 

1. Select the background Item(s) in the Item Tree or Item List or 3D View windows.  

2. On the Edit menu, click Remove from Background. 

See RapidManual and RapidLearning help system for other operations on editing Items, topic: Editing 3D 
Scene. 

mk:@MSITStore:C:/MT/docs/VM_tools/Creating_3D_Simulations&Trainings/2007-01-24_Creating_3DSimulations&Trainings_Telnov/VMEditor.chm::/html/manipulator.htm
mk:@MSITStore:C:/MT/docs/VM_tools/Creating_3D_Simulations&Trainings/2007-01-24_Creating_3DSimulations&Trainings_Telnov/VMEditor.chm::/html/transform.htm
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2.4 Enhancing 3D Model 

The 3D model can be enhanced by adding objects from the Object Gallery window (View menu > Object 
Gallery). The gallery objects can be added to the 3D model of the project using the context-sensitive 
command Add to Project in the Object Gallery window.  

 

See the RapidManual and RapidLearning help system for more information about the object gallery, topic: 
Object Gallery. 

2.5 Creating 3D Procedure 

There are two ways of creating a 3D procedure in RapidManual or RapidLearning:  

1. The first way is to generate a 3D procedure on the basis of a procedure document (XML file format). 
This way is much easier and mostly recommended. The document is usually created in accordance with 
a certain information standard and describes a procedure for completing a specific technical task. 

2. The second way is to create a 3D procedure manually in the Procedure Editor. The Procedure Editor 
provides efficient means of creating and changing structure of 3D procedure.  

The first way of creating a 3D procedure consists of two steps: 

1. Create a draft 3D procedure using the document. 

2. Add animations to the draft 3D procedure. 

The draft 3D procedure is created and changed automatically when the document is created and saved after 
editing. Section 2.8 describes how to create and edit the document. Section 2.6 describes how to add 
animations to the procedure. 

2.6 Editing 3D Procedure 

When creating a 3D procedure, the author adds animations to the draft procedure in the Procedure Editor. 
The animations are created by means of predefined actions and grouping elements such as action unions 
and other groups. 



Editing RapidAuthor Project  

 11 

2.6.1 Creating Actions  

Actions are the building blocks of 3D procedure.  An action is an operation associated with Item. Actions are 
shown in the Procedure Editor and can be grouped into steps, subtasks or other groups to suit the structure 
of technical procedure.  

By default, actions are executed sequentially. If you want to play several actions simultaneously, you have to 
group these actions under an action union. An action union is a special grouping item that is used to unite 
actions for their simultaneous playback. Action unions can contain other action unions and actions. 

Procedure 

To create an action: 

1. In the Procedure Editor, choose an existing group (by clicking it) or create a new grouping item (on the 

Procedure Editor toolbar, click  New Group). All actions must be part of a grouping item.  

2. Select the Item that you want to use in the action. 

3. On the Procedure toolbar, click   New Action. The New Action dialog appears.  Specify the required 
parameters for the new action. Please note that although it is possible to create new custom actions, we 
recommend you use actions without changing their internal structure of commands (atoms and 
functions). For more details about creating animations, see the RapidManual and RapidLearning help 
system, topic:  Basics of Creating Actions. 

To view an action: 

1. To view the animation, play it in the 3D View window. Before playing, click the Refresh button  (the 
Simulation menu). It is necessary to play procedure correctly. 

2. To control the playback of the animation, use the buttons  on the Simulation 
toolbar.  

To create a new grouping item: 

1. In the Action section of Procedure Editor, click a procedure element under which you want to create a 
grouping item. 

2. On the Procedure Editor toolbar, click  New Group. The Edit Group dialog box appears. 

3. In the Description box, enter a descriptive name of the grouping item; in the Child of box, choose the 
hierarchy level for a new grouping item; specify other parameters, and then click OK.  

2.6.2 Editing Actions 

Actions applied to Item use default parameters. If the action does not appear correct when viewed, it can be 
edited and corrected. This can be done by changing fields of actions. A field is a data element that is 
contained in any action and can be edited by the author. A field has a name and a value of a particular type. 
The changeable part of a field is underlined. 

Procedure 

To edit an action: 

1. Expand the action in the Procedure Editor.  
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2. Click the changeable part of a field that is underlined. Simple fields are edited by typing a new value. 
The other fields can be edited in the corresponding dialog boxes where you can change parameters 
with miscellaneous controls.  

See RapidManual and RapidLearning help system for other information on editing actions, topic: Editing 
Actions). 

2.6.3 Using Collections in Animations 

To create one action for several Items at once, you have to create a collection first. See the RapidManual 
and RapidLearning help system for more information about creating a collection, topic: Creating a Collection. 

Procedure 

To use a collection in animations: 

1.  Create a collection. 

2. In the Procedure Editor, choose an existing group (by clicking it) or create a new grouping item (click 

 New Group on the Procedure Editor toolbar). All actions must be part of a group. 

3. On the Procedure Editor toolbar, click   New Action. The New Action dialog appears.   

4. Specify the required parameters. In the third box of the New Action dialog box, click the underlined text. 
The Select Item or Collection dialog box appears. 

5. Click Select collection and choose the required collection, and then click OK. 

2.6.4 Creating Action Unions with Explosion Wizard 

Action unions can be easily created using the multi-step explosion wizard. The wizard helps to create 
animated exploded views. An exploded view is an illustration of an object that shows the relationship or order 
of assembly of various parts. It shows the components of an assembly slightly separated by distance, or 
suspended in surrounding space. Exploded views are often a good way of showing detail. The wizard can 
explode assemblies linearly (see Fig. 2. Linear Explosion) and radially (see Fig. 3. Radial Explosion).  

 

Fig. 2. Linear Explosion 
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Fig. 3.  Radial Explosion 

Procedure 

To create action unions using the explosion wizard: 

1. In the Procedure Editor, activate the action or action union which a new action union should follow. 

2. On the Edit menu, click Explode Assemblies.   

3. Follow the instructions of the wizard. 

NOTE: It is strongly recommended that the required viewpoint is to be set for the action union before clicking 
the Finish button of the wizard otherwise the current viewpoint is used for the action union. 

See the RapidManual and RapidLearning program help system for more information about the wizard, 
section: Creating Exploded Views. 

2.7 Creating 2D Images 

A 2D image can be created for any procedure action of the project. Each procedure action has its predefined 
viewpoint. By default, a 2D image is generated according to the predefined viewpoint of the active action. If 
necessary, before creating a 2D image you can choose your own viewpoint for the image by navigating in the 
3D View window. But note that using the Update 2D Images command (2D Image menu) will reset the 
custom viewpoint to the predefined viewpoint of the action associated with the 2D image. 

To create a 2D image: 

1. Click the 2D Preview tab to activate the 2D Preview window. 
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The 2D Preview window renders an outline of the view currently displayed in the 3D View window. 
The window is used for preparing and previewing a view that can be exported as a 2D image.  

NOTE: The 2D Preview window displays an outline of 3D model in the projection that was chosen in 
the 3D View window for the active action.  

2. Choose the desired moment of 3D procedure by dragging the time slider on the time ruler of 
Procedure Editor. 

3. If necessary, add callouts to the 2D preview image. To do this, on the 2D Image menu, click 
Generate Callouts. 

4. If necessary, change the appearance of the 2D preview image and its callouts. To do this, on the 
Tools menu, click Options, and then click 2D Image. See the RapidManual and RapidLearning help 
system for more details about changing the appearance of 2D image options, topic: 2D Image 
Options. 

5. To generate the 2D image, on the 2D Image menu, click Create 2D Image. The Edit 2D Images 
dialog box appears. 

6. Type the image name and description in the Project images box and Image description box, 
respectively, and then click OK.  

NOTE: On the time ruler, the red marker  indicates the moment when you created the 2D image. Point to 
the marker to see the name of the image and the time of its creation. Click the marker to open the Edit 2D 

Images dialog box. If you created several images for the same moment of time, the doubled red marker  
appears on the time ruler. Point to the doubled marker to see the names of the images and the time of their 
creation. To edit one of the images, click the doubled marker, and then choose the image name from a list of 
available images; the Edit 2D Images dialog box appears.  

If necessary, edit the ready-made 2D images. To do this, on the 2D Image menu, click Edit 2D Images.  In 
the Edit 2D Images dialog box, click Edit. The image will be opened with an external editor that was 
previously specified in the Options dialog box (Tools > Options > External Editors > Vector 2D Images or 
Raster 2D Images). If no external editor is specified, the built-in Cortona2D Editor Pro is used as a CGM 
editor.   See the RapidManual and RapidLearning help system for more information about choosing an 
external editor, topic: Choosing an External Editor for 2D Images. 

There is also another way of creating a 2D image using the Capture 3D command (2D Image menu). The 
Capture 3D command allows capturing an image of Items currently visible in the 3D View window and saving 
the image either in the chosen location or in the current project. In the current project the captured image is 
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saved in JPEG format. See RapidManual and RapidLearning help system for more information about 
capturing 3D, topic: Capturing 3D. 

2.8 Creating and Editing Document 

The Document editor is used for displaying and editing a document created in accordance with a particular 
standard. The document describes a procedure for completing a specific technical task. The Document Editor 
uses the XMetaL® XMAX as an embedded ActiveX component.  

To work correctly with the document follow the steps below: 

1. Create the document within the project (if the document does not exist). 

2. Edit the document (if necessary). 

2.8.1 Creating Document  

There are two ways of creating the document in the project: 

1. Generate the document (Document > Generate). 

The Generate command allows generating a draft document.  The draft document is generated on the 
basis of the project metadata and procedure steps (if the procedure steps are created in the Procedure 
Editor). 

NOTE: Each time the draft document is generated, the previous document is deleted and a new 
document is created from the current project metadata and procedure steps.  

2. Add the document (Document > Attach). 

The Attach command allows adding a ready-made document to the project. 

NOTE: Each time a new document is attached, this updates the current 3D procedure structure in the 
Procedure Editor: all procedure steps of the new document are added to the current 3D procedure 
structure, except for those steps that are identical to the procedure steps of the current 3D procedure 
structure.  

2.8.2 Editing Document 

After creating the document it can be necessary to add new steps to the document. When you save the 
document, the procedure steps are created automatically in the Procedure Editor. It is recommended that you 
use the context-sensitive commands for editing the document. The set of context-sensitive commands 
depend on the specification component used for the project. 

To add a procedural step to a document: 

1. In the document, click at the end of the step after which a new step should be created.  

2. On the Document Editor toolbar, click New Step  to create a step at the current hierarchy level 
(the red line on the button shows the current level of hierarchy).  

To choose another level of hierarchy, click and hold the black triangle of the button, then drag to the 
required hierarchy level and release the button. 

A new step appears below the caret position in the document. 
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3. Put in the desired text of the action. 

4. On the Document Editor toolbar, click Save . 

The step appears automatically in the procedure script of the Procedure Editor. 

See RapidManual and RapidLearning help system for information on other editing procedures of the 
document for example –  Inserting 2D Illustrations, Inserting Links to 2D Illustration Hotspots, Inserting Links 
to 3D Items. 

2.9 Basics of Creating Training (RapidLearning Only)  

RapidLearning is used for creating training publications. The basic part of the training publication is a training 
scenario. 

There are two ways of creating a training scenario: 

1. Generating the training scenario from the existing  3D procedure (see section 2.9.1) 

2. Creating the training scenario from scratch (see section 2.9.2) 

2.9.1 Generating Training Scenario from 3D Procedure 

You can generate a training scenario from the 3D procedure. The 3D procedure can be created from scratch 
or on the basis of the procedure document (see section 2.5). But the easiest way to create a training scenario 
from the 3D procedure is to reuse the procedure data of the existing projects for creating a training scenario.  

Procedure 

To generate a structure of training scenario from 3D procedure: 

1. In RapidLearning, on the File menu, click Open Project. The Open Project dialog box appears. 

2. In the corresponding boxes, choose the working space and the project that you are going to use; then 
click Open As. The Select Specification dialog box appears. 

3. Choose one of the training specifications and click OK. 

4. On the File menu, click Save Project As to save the project with a new name. 

5. In the lower right corner of RapidLearning, click the Scenario Editor tab to open the Scenario Editor 
window.  

6. On the Scenario menu, click Generate Scenario from Procedure.  

2.9.2 Creating Training Scenario from Scratch 

If required, a training scenario can be created manually by the author: 

1. Click the Scenario Editor tab to open the Scenario Editor window. 

2. In the Scenario Editor, click Add scenario to the project. 

3. To create the scenario of the training, you can give commands that are underlined control words. For 
example, if you would like to make a step in the training, you would click <add step>. Also there are 
command parameters that are underlined fields. Click on the underlined text to specify a new value.  
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4. Within the steps, add the required scenario elements: Operation, Request and Alert. To add a new 
scenario element in the Scenario Editor, under the group item click <add element>. 

See RapidLearning help system for other information on editing training scenario, topic: Creating Training. 

2.9.3 Creating Animations 

The procedure of creating animations in RapidLearning is similar to the procedure of creating animations in 
RapidManual (see section 2.6). The only difference is the Switch element in the structure. The Switch 
element allows alternative actions to be added to the procedure. In other words, the author of the training can 
create the training procedure in such a way that the trainee will see different animations, depending of the 
parameters the trainee enters. 

Procedure 

To add a new switch: 

1. In the Action section of Procedure Editor, click a grouping item or an action before  which you want to 
create a new Switch element.  

2. On the Procedure Editor toolbar, click   New Switch.  

3. In the Edit Group dialog box that appears, type in the descriptive name of Switch in the Description box. If 
you want to have the Switch element on the same hierarchy level as the grouping item, make sure that 
the root element is selected in the "Child of" list box and click OK. If you want to have the Switch element 
under the group, choose the name of the corresponding grouping item in the "Child of" list.  

2.9.4 Using Scenario Elements 

Whenever the structure of training scenario is built, the author needs to add and modify scenario elements in 
the training scenario. There are three scenario elements: Operation, Request, and Alert. The Operation 
element is used to set the task for the trainee (expected activity) and to specify the response of the training 
system when completed. The Request elements are used to request information from the trainee. The Alert 
elements are components that display a pop-up text message in the training.  

The most frequently used element is the Operation element. The Operation elements are added to the 
training scenario to ask the trainee to locate and select Items in the specified order in the 3D View window. 
Elements are added to the scenario using the context-sensitive commands and appear in the Scenario 
Editor.  

Procedure 

To add a new Operation element: 

1. In the Scenario Editor, click <add element>.  

2. Select Operation, and then All items or Any of items.  

3. Click Browse, and then choose the Item(s) you want. Click OK.  

4. If you want to add Items to the Operation element, in the Scenario Editor, click <add item> and choose 
the Item from the list.  

5. To type the text message, use the insertion point as shown in the figure below: 

  

6. If needed, add a question by using <add question>.  

mk:@MSITStore:C:/MT/Help_projects/VTEditor_trainer_renamed_neutrally/VMEditor.chm::/html/elements_operation.htm
mk:@MSITStore:C:/MT/Help_projects/VTEditor_trainer_renamed_neutrally/VMEditor.chm::/html/elements_request.htm
mk:@MSITStore:C:/MT/Help_projects/VTEditor_trainer_renamed_neutrally/VMEditor.chm::/html/elements_alert.htm
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7. To specify the reaction of the training system in case of the trainee’s correct action, use <add 
animation>, <add message>.  

8. To specify parameters for conditional jumps, use <set parameter>.  

To add a new Request element: 

1. Make sure you have a scenario parameter or add a new one.  

2. In the Scenario Editor, click <add element>.  

3. Select Request, in the Prompting box, type in the explanatory text and in the Parameter list, click the 
parameter of your choice.  

4. Click OK.  

To add a new Alert element: 

1. In the Scenario Editor, click <add element>. 

2. Select Alert, and one of the notifications you want: Note, Warning, and Caution.  

3. Type a description of the alert message.  

4. Click OK  

See RapidLearning help system for other information on editing training scenario, topic: Creating Training. 

2.10 Publishing Training or Procedure Publications 

Once the procedure (or training) has been completed and the preview is satisfactory, use the Publish 
command in RapidManual (or RapidLearning) to generate the procedure or training publication (File > 
Publish).  

NOTES:  

1. The appearance and visualization mode of the training or procedure publication are defined by the 
specification used. The appearance and the mode can be edited using a set of options in the Publish 
Options dialog box (Tools > Publish Options). See section 3 for more details about specifications.  

2. To preview the training or procedure publication, on the Standard toolbar, click Preview .  

3. You can also use the Publish As command that allows publishing the procedure or training publication 
in the chosen format, for example – PDF. 
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3 Working with Specification Components 

3.1 Specifications: Overview 

RapidManual and RapidLearning use a set of customizable components (specification components) for 
authoring the procedure and training publications in accordance with various information standards (for 
example, S1000D Issue 4.1, DITA 1.1, ATA 2200 AMM). 

Each RapidAuthor project contains information about the specification component (specification) used for 
creating or opening the project. When creating a new project, the user should choose a specification 
component for the project.  

A set of specification components can be extended for each RapidAuthor tool.  

RapidManual and RapidLearning use the specification components of procedure and training type (procedure 
and training specifications). Currently, RapidManual and RapidLearning use the following specifications: 
S1000D Issue 2.3, Procedure, S1000D Issue 2.3 Training, ATA 2200 AMM, DITA 1.1 Task, Generic 
Procedure, Generic Training, Rapid Work Instruction, S1000D 4.0 Procedure, S1000D 4.0 Training, and 
S1000D 4.1. The user can choose a language for the specification. 

Each specification is designed for a particular information standard and defines the following: 

 Set of metadata fields required in accordance with the standard.  

 Set of declarations which describe the training and procedure appearance (for example, actions 
names, scenario structure, default parameters of actions and so on).  

 Set of additional software components that allow the training and procedure authoring in 
accordance with the standard.  

 Set of additional software components which allow publishing the procedure and training 
publications in formats required by the standard (for example, S1000D Issue 2.3 Training XML or 
S1000D Issue 2.3 Procedure XML) or additional formats requested by a customer.  

 Set of resource files (for example, images, styles, scripts) that defines appearance and 
functionality of the procedure and training publication.  

NOTE:  

1. Application can support one specification at a time.  

2. If the required specification component is not installed on your computer, the project cannot be opened 
with the command File > Open Project > Open. You can open the project using the command File > 
Open Project > Open As and choosing another specification component for the project.  

3. In RapidManual and RapidLearning you can open projects that use specification types other than 
procedure and training types (for example, IPC specifications). For this purpose use the Open As 
button (File > Open Project). This operation will result in loss of some specific data but 3D data will not 
be lost and can be reused.  

For more information about changing specification component of the project, see the section below. 
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3.2 Changing Specifications  

To change the current specification component for a project, use the Open As command (File > Open Project 
> Open As button).  

NOTE: The name of the current specification is displayed in the status bar. 

Also use the Open As command: 

 If the required specification component of the project is not installed on the computer. 

 If the project to be opened is created using the RapidAuthor tool other than RapidManual or 
RapidLearning (for example, RapidCatalog). This allows reusing the 3D data of the project for 
creating the procedure and training publications.  

 If you want to reuse the data of the project created in accordance with a certain specification in 
RapidManual or RapidLearning for creating a new project in accordance with another specification 
in RapidManual or RapidLearning.  

Procedure 

To change a specification for the existing project: 

1. On the File menu, click Open Project. 
The Open Project dialog box appears.  

 

2. In the corresponding boxes, click the name of the working space and the name of the project for which 
you want to choose a new specification, and then click Open As. 
 



Working with Specification Components  

 21 

 

      The Select Specification dialog box appears. 

3. In the Select Specification dialog box, choose the required specification by clicking its name in the 
Name column, and then choose a language for the specification.  

 

4. Click OK to save the choice and close the dialog box.  

For reusing the data of the existing project in order to create a new project with other specification, it is 
recommended that the user should create a new working space for such project and use the export-import 
procedure for creating a new project as follows: 

1. In RapidManual or RapidLearning, create a new working space for a project created with some 
procedure or training specification (Tools > Select Working Space  > New button). 

2. Import the project to the newly created working space (Tools > Manage Projects > Import button). It is 
supposed that the project was previously exported from RapidManual or other RapidAuthor tool. 

3. Open the project using the desired specification as described above (File > Open Project > Open As 
button). 

3.3 Adding Specifications 

The Import specification button is used for adding a new specification (in VMS file format) to the list of 
available specifications.  
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Procedure 

To import a new specification: 

1. On the File menu, click New Project. 
The New Project dialog box appears.  

2. In the New Project dialog box, click Import specification. 
The Import Specification dialog box appears.  

3. Choose the specification file and click Open. 
The name of the new specification appears in the Use Specification area of the New Project dialog box. 

4 Useful Additional Operations  

4.1 Adding Data to Existing Project 

To add data to the existing project, follow the procedure below: 

Procedure 

1. Start RapidGenerator. 

2. From the Tools menu, choose Select Working Space.                                                                              
In the Select Working Space dialog box, click the desired working space, and then click OK. 

3. To choose the existing project, from the File menu, click Open Project. 
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4. In the Open Project dialog box, click the desired project, and then click OK. 

5. Choose the RapidDataImportTool plug-in by clicking its name in the Plug-in name box.  

6. To choose the import profile, click Settings.                                                                                                                                        
In the Choose profile dialog box, select the required import profile.          

7. In the Choose Profile dialog box, click the name of the required profile. For more information about the 
current dialog box, click the Help button.  

8. To start importing the data, click Start. 

9. In the dialog box, select the supported geometry file to be imported, and then click Open. 

NOTE: The options available in the dialog box depend on the chosen profile. 

10. The time required for the import procedure depends on the amount of input data. RapidGenerator saves 
the project when the import is finished.  If the import setting other than the default ones are used, be 
sure to save the project when the import is finished (File menu > Save). 

4.2 Additional Optimization of Existing Project  

If you cannot choose any suitable representation for the significant amount of Items from a standard set of 
representations automatically generated by RapidGenerator, a new level of detail (LOD) can be added for 
each Item of the existing project. To do this, process the project in RapidGenerator with the settings specified 
below.  

Procedure 

To add an additional LOD for all items of the existing project: 

1. Start RapidGenerator. Choose the RapidDataImportTool plug-in. 

2. Select the working space Tools > Select Working Space. 

3. Open the project File > Open Project. 

4. Specify the settings for additional optimization. Choose Tools > Options and click the 
Representations tab. 
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5. In the Representations list, choose the Super quality level, and then click Remove. Repeat this for all 
existing levels. 

6. Click Add and enter a name for a new level of detail. 

7. Select the Quality-based type and enter a reasonable quality value. Click OK. 
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8. Click the Optimization tab and in the Optimization of existing projects field, choose Make for all 
parts option as shown below.  
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9. Clear the Allow to replace LODs box and the Set the smallest representation as current box as 
shown below. 

 

10. To use the specified settings for updating the projects later on, save the settings into a file. To do this, 
click Save, and then specify a new file name and location.  

The saved file includes information about all RapidGenerator settings that can be specified via the  
Tools > Options command. The file can be used to restore the specified settings in the future (Tools > 
Options > Load). 

11. Click OK to close the Options dialog box. 

12. Choose Action > Start Optimization.  

13. When the optimization is completed, save the project (File > Save) if the project has not been saved 
automatically in accordance with the default value of the Automatically save processed project 
setting (Options > General tab > Automatically save processed project).  

To restore the default settings: 

1. Choose Tools > Options, click the Representations tab, and then click Restore Defaults. 

2. Choose Tools > Options, click the Optimization tab, and then click Restore Defaults. 
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4.3 Exchanging Projects between Authors 

This section describes the mechanism that RapidManual/RapidLearning and RapidGenerator applications 
provide for exchanging data. 

Procedure 

To export project(s): 

1. Start RapidManual/RapidLearning or RapidGenerator. 

2. Select the working space that contains the project(s) to be exported. To do this, click Tools and choose 
Select Working Space. In the Select Working Space dialog box, choose the name of working space 
by clicking it. Click OK.  

3. On the Tools menu, click Manage Projects. 

4. Select the project to be exported from the Project box on the left, and then click Export. Please note 
that all projects can be selected by clicking Projects. 

5. Specify the location where the selected project(s) will be saved in the Save in field. 

6. In File name, type a name for the project archive (VMP file), and then click Save. 

7. Click OK to close the Manage Projects dialog box. 

To import project(s): 

1. Start RapidManual/RapidLearning or RapidGenerator. 

2. Select the working space to contain the project(s).  

3. On the Tools menu, click Manage Projects. 

4. Click Projects in the Project box on the left, and then click Import. 

5. In the Import Project dialog box, choose and open the folder containing the project archive (VMP file).   
Select the project archive by clicking it, and then click Open. 

6. If the project archive contains several projects, the Import Multiple Projects dialog box appears. In the 
Projects list, select the project(s) to be imported. Click OK. Please note that, by default, all projects in 
the Projects list appear selected. 

7. Click OK to close the Manage Projects dialog box. 

Authors can also exchange 3D data of the projects. 

To export a subset of the project 3D data: 

1. Open the desired project in RapidManual/RapidLearning. 

2. Select the Items to be exported in the Item Tree or Item List or 3D View windows. 

3. On the File menu, click Export Selection. 

4. Specify the location where the selected part of project will be saved in the Save in field. 

5. In the File name box, type a name for the part of project archive (VMP file), and then click Save. 
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To add 3D data to a project from other project archive (VMP file): 

1. Open the project in RapidManual/RapidLearning. 

2. Select the working space which you wish to contain the project(s).  

3. On the File menu, click Add Project. 

4. In the Add Project dialog box, choose and open the folder containing project archive (VMP file). Select 
the project archive by clicking it, and then click Open. 

5. Save the updated project. 

4.4 Recommendations on Increasing Publication Performance 

The following are recommendations for increasing the performance of the procedure or training publications. 

For increasing the performance: 

 Estimate the performance by studying the performance related characteristics of the project (File > 
Project Info). 

 Optimize 3D data of the project. 

 Publish the procedure or training publication in 2D mode (if the optimization does not help). Choose 
Tools > Publish Options > Illustration Type > 2D only. 

4.4.1 Estimating Publication Performance 

The following characteristics affect the 3D data file size and correspondingly the publication loading time: 

 Number of unique representations. 

 Total number of faces. 

The following characteristics affect 3D viewer performance that can be measured in fps (frames per second):  

 Total number of representations. 

 Total number of faces. 

The greater the numbers, the lower the performance. 

4.4.2 Optimizing 3D Data 

4.4.2.1 Remove Unnecessary Items 

Reduce the file size by removing hidden parts and small parts, e.g. screws, bolts, rivets etc., from the 
background assemblies. As the background assemblies are used to help orientate the user, keep only the 
main items that will allow the user to recognize the assembly. 
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Full Assembly 

 

Reduced Assembly 

4.4.2.2 Merging Items  

The performance of publication can be increased by merging the background assemblies.   

Procedure 

To merge Items which are children of one assembly Item: 

 Right-click the assembly Item in the Item Tree window and click Merge Assembly. 



Useful Additional Operations  

 30 

4.4.2.3 Create a New Level of Detail 

If no appropriate level of detail for 3D data can be chosen from the standard set because one LOD is too 
heavy whereas the next smaller LOD is too simplified, a new LOD can be added to the project using 
RapidGenerator. See section 4.2 for more information about adding a new level of detail. 

 


