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Introduction: General Data Flow Diagram

Introduction
This document gives practical recommendations on how to create the IPC (Illustrated Parts Catalog)
publications using the RapidAuthor tools.
The IPC publication is the RapidAuthor publication of IPC type. The IPC publication is a documentary unit
that usually contains two components: illustrations and Detailed Parts List (DPL) table. Several IPC
publications can be compiled together to make an interactive IPC.
The following RapidAuthor tools are used to create the IPC publication:
RapidCatalog is a powerful authoring application that provides a visually oriented approach to allow the user
to rapidly build interactive IPC publications. The IPC publications can include either 2D or 3D data or both,
and provide the user with drill-down mechanisms and a page-based navigation system similar to traditional
2D and text. RapidCatalog uses a set of customizable components (specification components) for authoring
the IPC publications in accordance with various information standards (for example, ATA iSpec 2200,
S1000D Issue 2.3 IPD, S1000D Issue 4.0 IPD).
RapidGenerator is an application that is used to preprocess and import data exported from CAD/PLM
systems. The preprocessed 3D models are used in RapidManual, RapidLearning and RapidCatalog. To
import 3D data, RapidGenerator uses a set of customizable components (plug-ins) designed for different
CAD systems. A customer-specific plug-in can be developed by ParallelGraphics on demand. This tailored
plug-in can import the customer’s source data (including PDM data) in the most effective way. Provided that
the source data contains the required information, the plug-in can generate a preliminary DPL table and
automatically link it with the corresponding graphics.
RapidAdministrator is a helper application that provides the advanced abilities to manage projects and
working spaces for RapidAuthor.
NOTE: Compiling an interactive IPC of separate IPC publications is out of scope in this document.
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1 Process Layout and Basic Operations
To create the IPC publication, the author should perform the following basic steps:
1. Preparing input data for the RapidAuthor project.
3D data and additional PDM data are obtained from CAD systems.
2. Creating the RapidAuthor project.
RapidAdministrator is used for creating a working space for the projects.
RapidGenerator is used for creating a new project and for importing the input data into the project.
3. Editing the RapidAuthor project.
RapidCatalog is used for editing the project.
4. Publishing the IPC publication.
RapidCatalog is used for publishing the IPC publication.

Note that Cortona3D technology allows reusing content across functional areas. The RapidAuthor project
created using one RapidAuthor tool can be reused by other RapidAuthor tools. Once created by
RapidGenerator and edited by any RapidAuthor tool, the RapidAuthor project can be reused several times to
create the entire range of supported documentary units including IPC publications.

Pay attention that RapidGenerator is also available in the RapidCatalog environment. To open
RapidGenerator within RapidCatalog, from the File menu, choose Import Data.
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1.1

General Data Flow Diagram

The general data flow diagram for creating the IPC publication is shown in Fig. 1.
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Fig.1. Data flow diagram of creating the IPC publication
Box – an application; parallelogram – data. Dimmed parallelograms – input and output data used in the
development process.

1.2

Preparing Input Data for RapidAuthor Project

The following set of input data is required for creating the RapidAuthor project:
1. 3D data from CAD.
2. Additional PDM data that can be used for automatic generation of DPL table.

1.3

Creating RapidAuthor Project

The RapidAuthor project can be created using the following basic steps:
1. Creating a working space.
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2. Creating an empty project.
3. Adding data to the project.
RapidAdministrator should be used to create a working space. To start RapidAdministrator, choose Start >
All Programs > Cortona3D > RapidAdministrator.
RapidGenerator is used to create an empty project and to add data to the project. To start RapidGenerator,
choose Start > All Programs > Cortona3D > RapidGenerator.
The RapidAuthor project stores 3D models and other related data such as images, metadata and technical
documents. A working space is a specially organized set of working folders that contain RapidAuthor
projects. The working space has a descriptive name. In the working space the author creates a new project
and fills the project with the input data.
Procedure
1. To create a working space:


Start RapidAdministrator.



Click All Configurations, and then click Create.



In the Working space properties area that appears, type name, description (optionally), and author
(optionally).



In the Base path, specify the location where you want to locate the folders of the working space. You
can also click the button



to specify the existing folder.

Click Apply.

See the RapidAdministrator help system for more information about managing the working folders.
2. To create a new project:


Start RapidGenerator.



From the Tools menu, choose Select Working Space.
In the Select Working Space dialog box, choose the desired working space, and then click OK.



On the File menu, click New Project.
The New Project dialog box appears.



In the Project Name box, type the descriptive name for the project. Make sure that the dialog box
shows the proper working space for the new project, and then click OK. This creates a new empty
project (that is a project without any geometric data and DPL data) in the current working space.
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3. To import data to the project:


Start RapidGenerator.



Choose the RapidDataImportTool plug-in by clicking its name in the in the Plug-in name box.



To choose the required import profile, click Settings. The Choose Profile dialog box appears.



In the Choose Profile dialog box, click the name of the required profile. For more information about the
current dialog box, click the Help button.



To start importing the input data, click Start.



In the dialog box that appears, select the supported geometry file to be imported, and then click Open.
NOTE: The options available in the dialog box depend on the chosen profile. In general, the dialog box
allows you to select 3D data and additional PDM data (optionally).



The time required for the import procedure depends on the amount of input data. RapidGenerator
saves the project when the import is finished. If no default import setting are used, be sure to save the
project when the import is finished (File menu > Save).
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2 Editing RapidAuthor Project
The RapidAuthor project can be edited using RapidCatalog. To start RapidCatalog, choose Start >
Programs > Cortona3D > RapidCatalog.
NOTE: When RapidCatalog is started on virtual machine for the first time, it could be required to change the
renderer for proper display of 3D model. To change the renderer, click Tools > Options > 3D View >
Renderer.
The following basic steps are used for editing the RapidAuthor project:

2.1

Step 1: Opening RapidAuthor Project

Once the RapidAuthor project has been created using RapidGenerator, it can be opened in RapidCatalog.
Procedure
To open the project:


On the File menu, click Open Project. In the upper section of the Open Project dialog box, choose
the same working space that was specified in RapidGenerator for the project, then in the lower section
click the project to be opened, choose the language and click Open.
NOTE: If the name of specification component is not specified for the project, the Select Specification
dialog box appears. This allows choosing a specification component for the project.



When 3D data is imported into a project, it is initially hidden in the 3D View window. To display the
hidden Items, select them in the Item Tree and make the Items visible by using the Show Solid
command (on the 3D View menu, point to Hide/Show Selection, and then click Show Solid).



Use the Save Project command from the File menu to save your work.

2.2

Step 2: Creating and Editing DPL Table

If DPL table was not automatically generated using RapidGenerator, it can be created manually using
RapidCatalog. The DPL table is created and edited in the DPL Table window.

Follow the sub-steps below to create and/or edit DPL table.

2.2.1

Add a New DPL Row

Empty DPL table has only a header that is why it is necessary to add rows to the DPL table.

Procedure
To add a new row to the DPL table:
1. Right-click a DPL row, and then click New DPL Row to open the New DPL Row dialog box.
NOTE: A new DPL row can be added by clicking Click here to add a new row at the end of DPL table.
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2. Enter a new unique part number in the PART NUMBER box or select the existing one from the list
below the box. If the part number for the new row is undefined or is unnecessary, leave the box empty
allowing RapidCatalog to specify unique ID that begins from “NO-NUMBER”.
3. The new DPL row can be linked with the corresponding Item by selecting the required Item(s). To do
this, clear Filter list for matching PART NUMBER, and then select one or several Items from the list
below.

4. Click OK.
The new DPL row will appear at the end of the DPL table.
NOTE: The linkage can be established later (see section 2.2.3).

2.2.2

Fill DPL Data

Once the rows have been added, the next step is to populate them with data.
The DPL data are represented in the form of entries.

An Entry is a coded element used to provide different types of information. There are entries with parameters
(for example, ALT PART NUMBER) and entries without parameters (for example, MATCHED PART). You
can add a new entry by choosing one from a list of predefined entry templates.
A Parameter is a highlighted underlined element that can take on different values.
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A Value is data of specific type assigned to a parameter. A value can be entered by either typing a value or
choosing the necessary value from a list of predefined values.
NOTE: A list of some values and their descriptions can be added and edited using the Reference Tables
command (see section 4.6 for editing reference tables).
To start editing DPL data, switch to the edit mode by double-clicking the required data. In this mode entries
can be added or deleted and values can be changed, typed, copied or pasted. To exit the edit mode, click
anywhere in the DPL table.
Procedure


Double-click any column to switch to the edit mode.

To assign a value to a parameter:


Click the parameter and then type or choose the required value.

FOR EXAMPLE:
To assign a value to the KEYWORD parameter:
1. Click the KEYWORD parameter.

2. Type the required value.

To assign a value to the INDENT parameter:
1. Click the INDENT parameter.

2. Choose the required value from a list of predetermined values.

To add a new entry:
1. Click the <add entry> field. A list of available entries appears.
To insert a new entry above the chosen entry, right-click any entry, and then choose Insert Entry.
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2. Choose the required entry from the list of available entries.
The entry will appear at the end of the cell (the <add entry> command) or above the chosen entry (the
Insert Entry command).

To delete an entry:


Right-click the required entry, and then choose Delete Entry.

To change the parameter of an entry:
1. Click the parameter, and then type the required value.

2. Click anywhere outside the edited cell to switch off the edit mode.

2.2.3

Establish Links between DPL Rows and Items

After creating the DPL table, the author should establish links between the DPL rows and Items. Each Item
should be assigned to the corresponding DPL row.
The links are established and edited in the DPL Table window.
The

sphere icon beside a DPL row indicates that the row is linked with the corresponding Item.

See the RapidCatalog help system for more information about DPL table (topics: DPL Table Window:
Overview, DPL Editor).
Procedure
To establish/edit links between a DPL row and Item:
1. Select the Items to be associated with a particular DPL row. This step is optional but might be helpful.
2. Right-click the required DPL row, and then click Edit Links with Items to open the Links Editor dialog
box. You can also double-click the sphere icon of the required DPL to open the Links Editor dialog
box.
3. Select the required Item(s), and then click Link. The Items in the list of Available Items can be selected
directly or using any method available (See section 4.10 for selecting Items.)
4. Once the selected Items have appeared in the list of Linked Items, click OK. The sphere icon appears
beside the DPL row to indicate that this row is linked with the corresponding Item.
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NOTE: The DPL row can also be linked with Item by dragging the Item(s) from the Item Tree window and
dropping it on the required DPL row.

2.2.4

Validate DPL Table

There are mandatory metadata whose values must be filled in to ensure that the IPC publication is valid. The
author can check and correct, if necessary, the DPL table using the Validate command.
Procedure
To validate DPL table:


Right-click any DPL row, and then click Validate.
If the DPL table contains any missing mandatory metadata, the Validate DPL Table dialog box
displays the DPL rows in which these mandatory metadata are omitted.



In the Validate DPL Table dialog box, switch to the edit mode and enter the missing values.



Once all missing metadata have been filled in, click Close.

NOTE: Any changes or selection made in the Validate DPL Table dialog box are applied synchronically to
the DPL Table.
As soon as the missing mandatory metadata have been entered in the required DPL row, the row disappears
from the Validate DPL Table dialog box.

2.3

Step 3: Editing Items

Once the required links have been established between DPL rows and Items, the author should edit Items in
the Base. This may include deleting irrelevant Items, choosing and changing the representations of Items. To
start editing, activate the Base (in the IPC Pages window, double-click Base). The Base contains all Items of
the project.
Procedure
To delete Item:
1. Select the Item(s) to be deleted in the Item Tree or Item List or 3D View windows.
2. On the Edit menu, click Delete.
There are two ways to choose representations for one Item or a group of Items: by name or weight. The first
method allows the author to choose the most suitable representation of the previously selected Items by
specifying the name that was assigned to each Item during the step of data preparation in RapidGenerator.
The second way uses the percentage parameter that is the number of triangles in the polygonal mesh. The
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first method is preferable for groups of Items since RapidGenerator uses robust simplification algorithms
comprising a visual quality check.
Procedure
To choose representations by name:
1. Select Item(s) for which you want to change the representation.
2. Click Choose Representations by Name from the Edit menu or click Choose Representations by
Name on the Standard toolbar.
3. In the Choose Representation by Name dialog box, choose the name of representation, and then click
OK.
To choose representations by weight:
1. Select Item(s) for which you want to change the representation.
2. Click Choose Representations by Weight from the Edit menu.
3. In the Choose Representation dialog box, specify the Weight parameter. The closer parameter to 0, the
more simplified mesh of Item is selected from the list of different representations. Click OK.
To edit the current representation properties for one or more Items:
1. In the Item Tree window, select the Item(s), whose representation you want to edit.
2. From the Edit menu, choose Change Representation Properties.
The Edit Representation Properties dialog box appears.
3. Set the required parameters and click OK.
The changed representations are saved as a new representation for each selected Item and the
representation becomes current for each selected Item.

See the RapidCatalog help system for other operations on editing Items (topics: Working with 3D Model).
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The 3D model can be enhanced by adding objects from the Object Gallery window (View menu > Object
Gallery). The gallery objects can be added to the 3D model of the project using the context-sensitive
command Add to Project in the Object Gallery window.

See the RapidCatalog help system for more information about the object gallery (topics: Working with
Object Gallery).

2.4

Step 4: Creating and Editing IPC Pages

The next step is to add pages to the project and fill them with the required data.
An IPC page contains information about:


A set of DPL rows that are shown when the author activates the IPC page (active DPL table rows);



Corresponding subset of Items with their defined positions that are visible when the author activates
the page;



Viewpoint (camera position) from which the author sees the Items when the IPC page is activated;



Name that is shown as the corresponding IPC page description in the IPC publication.

2.4.1

Creating an IPC Page

The IPC pages are created in the IPC Pages window and are arranged in a tree-like hierarchical structure. To
start working on the new IPC page, the author should name the page and activate it.
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Procedure
To create an IPC page:


Right-click somewhere in the IPC Pages window, and choose Insert New.

NOTE: The newly created page has the same set of Items as the Base and has no active DPL rows.
To rename an IPC page:
1. Right-click the page and choose Rename.
2. Type the desired name.
To activate an IPC page:


Either right-click the page name and select Activate or double-click the page name.

2.4.2

Creating a New Page Based on an Existing Page

Any IPC page can be duplicated in order to use the clone as a base for a new page. The clone page contains
the same Items and same active DPL rows as the page it was cloned from. In the IPC pages tree, the clone
page always appears as a child of the page it was cloned from.
Procedure
To clone a page:


Right-click the desired page in the IPC Pages window, and choose Clone.

NOTE: Activate the newly created page to start working on it.

2.4.3

Creating Multi-Step Animated Transitions

The IPC pages hierarchical structure is used for creating animated transitions between pages in the IPC
publication. An animated transition is a smooth transition from one page to another that gives the user's eyes
a chance to track the location while the view changes. The animated transition is achieved if IPC pages have
a common parent page, as shown in the figure below.

In this case, transition between two child pages (View B – View C) of one common parent (View A) is
animated and is made through their common (nearest) parent (View B – View A – View C). Here View A is an
intermediate view between View B and View C.
When creating an animated transition with several intermediate views, it is better to use intermediate pages.
Intermediate pages are used only for creating the multi-step animated transitions and the intermediate pages
are not included in the list of available pages in the IPC publication.
Procedure
To insert an intermediate page:


Right-click the page that will be a child of the intermediate page, and then click Insert Intermediate.

To mark/unmark a page as intermediate:


Right-click the page to be marked/unmarked as intermediate, and then click Intermediate.

See RapidCatalog help system for more information about creating animated transitions (topic: Creating
Animated Transitions).

2.4.4

Recommending an IPC Page

Item can be displayed differently on different IPC pages. A particular IPC page on which Item is best
displayed can be chosen and marked as recommended. The recommended page provides the best view of
Item linked with a DPL row. By default, none of IPC pages are marked as recommended (the None option is
selected). There are two commands that allow marking an IPC page as recommended: Recommend this
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Page and Set Recommended Page. The Recommend this Page command allows marking the active IPC
page as recommended for the chosen DPL row linked with the corresponding Item. The Set Recommended
Page allows marking one of the IPC pages as recommended by choosing the required IPC page from a list of
IPC pages. The list of IPC pages includes only those IPC pages on which the chosen DPL row is active.
Procedure
To set the recommended page, do one of the following:


Select one or more DPL rows, right-click them, and then choose Recommend this Page. The active
page becomes recommended.



Right-click the required DPL row, point to Set Recommended Page, and then click the required page
in the list.



Drag the page from the IPC Pages window and drop it on the required DPL row.

2.4.5

Setting IPC Page Viewpoint

A viewpoint should be assigned to each IPC page. This viewpoint will be shown whenever the IPC page is
activated, in both RapidCatalog and IPC publication. The viewpoint contains information on:


Camera position from which the user views the 3D model.



Center of rotation which is used when the user rotates or moves closer/further 3D model.

NOTE: When switching between the IPC pages the current viewpoint can be used instead of the viewpoint of
the activated page. To do this, use the Freeze Camera command from the 3D View menu.
Procedure
To set the viewpoint for an IPC page:
1. Activate the IPC page.
2. Select Item(s) whose center will be the center of rotation. If there is no selected Item, the center of all
currently visible Items is considered.
3. Using the mouse and keyboard, choose the camera position, so that the desired view is achieved in the
3D View window.
4. On the 3D View menu, click Set Page Viewpoint.
See the RapidCatalog help system for setting the rotation center (topic: Navigation Types: SPIN).

2.5

Step 5: Editing Views on IPC Pages

On the active IPC page you can customize the DPL table and the 3D model of the project, create and edit 2D
images. For editing views on IPC pages, use the following actions:

2.5.1

Deleting Items

It is possible to remove Items from an IPC page.
Procedure
To delete Item:
1. Select the Item(s) to be deleted in the Item Tree or Item List or 3D View windows.
2. On the Edit menu, click Delete.

To see the deleted Item(s) in the Item Tree or Item List windows:


On the Edit menu, click Show Deleted Items. The deleted Item appears with its icon crossed
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To restore deleted Item(s):
1. Select the deleted Item(s) in the Item Tree or Item List windows.
2. On the Edit menu, click Restore.

2.5.2

Setting Items as Background

Items that represent the outer environment to the main Items can be made semi-transparent on the active
IPC page. To do this, use the Set as Background command.
Procedure
To set Item(s) as background:
1. Select Item(s) in the Item Tree or Item List or 3D View windows.
2. On the Edit menu, click Set as Background.
To restore the initial appearance of the background Item(s):
1. Select the background Item(s) in the Item Tree or Item List or 3D View windows.
2. On the Edit menu, click Remove from Background.

2.5.3

Activating DPL Rows on IPC Pages

The author can customize the DPL table by activating or deactivating the required DPL rows on each IPC
page. Active DPL rows are those rows that are visible on the active IPC page. Inactive DPL rows are those
rows that are invisible on the active IPC page and are not displayed when the IPC page is viewed in the IPC
publication. By default, the DPL rows of a new IPC page are inactive. The text is dimmed in the inactive DPL
rows. When DPL rows are activated on the page, the activated rows change their color to black.

Procedure
To activate a DPL row on the IPC page, do one of the following:


Right-click the required DPL row, and then click Activate on this Page.



Drag the page from the IPC Pages window and drop it on the required DPL row.
The dragged page is marked as recommended for the chosen DPL row.

NOTE: All DPL rows whose linked Items are visible on the active page can be activated. To do this, right-click
the active page in the IPC Pages window, point to DPL Rows, and then click Activate with Visible
Geometry.
To deactivate those DPL rows whose linked Items have been deleted from the active page, right-click the
active page in the IPC Pages window, point to DPL Rows, and then click Deactivate with Deleted Geometry.

2.5.4

Creating Exploded Views

Exploded views can be created on the active IPC page. Exploded view is an illustration of an object that
shows the relationship or order of assembly of various parts. It shows the components of an assembly slightly
separated by distance, or suspended in surrounding space. Exploded views are often a good way of showing
detail.
Exploded views can be created either manually using the Set Position command or with the help of the
multi-step Explosion Wizard. The wizard can explode assemblies linearly (see Fig. 2. Linear Explosion) and
radially (see Fig. 3. Radial Explosion). Use the
Explosion Axial Lines command from the 3D View
menu to view the explosion direction in the exploded views.
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Fig. 2. Linear Explosion

Fig. 3. Radial Explosion
Procedure
To change the position of Items using the Set Position command:
1. Select the Item(s), whose position should be changed.
2. From the Edit menu, choose Set Position.
The Edit Position dialog box opens and the manipulator appears in the 3D View window.
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3. Change the position of the selected Item(s) using the options of the Edit Position dialog box and
moving the manipulator in the 3D View window.
See the RapidCatalog help system for more information about the Set Position command (topics: Setting
Position).
To start the Explosion Wizard:


On the Edit menu, click Explode Assemblies.

See section 4.8 for more information about creating the exploded views.

2.5.5

Creating 2D Image

A 2D image can be created for the active IPC page. There are two ways of creating a 2D image.
1. Using the Create 2D Image for Current Page command (2D Image menu). The command allows
creating a vector image in CGM file format.
2. Using the Capture 3D command (2D Image menu). The Capture 3D command allows capturing the
image of Items currently visible in the 3D View window and saving the image either in the chosen
location or in the current project. In the current project the captured image is saved as a raster image in
JPEG format. See the RapidCatalog help system for more information about capturing 3D (topic:
Capturing 3D).
The below procedure describes how to create a 2D image using the Create 2D Image for Current Page
command.
Procedure
To create a 2D image for an IPC page:
1. Activate the page for which a 2D image is created.
2. Click the 2D Preview tab to activate the 2D Preview window and to see the 2D image preview.
The 2D Preview window renders an outline of the view currently displayed in the 3D View window. The
window is used for preparing and previewing a view that can be exported as a 2D image.
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3. Choose the position and orientation of Items by navigating in the 3D View window.
4. If necessary, add callouts to the 2D preview image. To do this, on the 2D Image menu, click Generate
Callouts.
5. If necessary, change the appearance of the 2D preview image and its callouts. To do this, on the Tools
menu, click Options, and then click 2D Image. See the RapidCatalog help system for more details
about changing the appearance of 2D image options (topic: 2D Image Options).
6. Once the 2D preview image has been prepared and previewed, generate the 2D image. To do this, on
the 2D Image menu, click Create 2D Image for Current Page. The Edit 2D Image dialog box appears.
7. In the Edit 2D Images dialog box, type the image name and description in the Project images box and
Image description box, respectively, and then click OK (see section 2.5.6 for more information about
editing 2D images).
NOTE: The name of the image represents the name of the image file used to store 2D image.
8. Click the 2D Image tab to activate the 2D Image window and to view the ready-made 2D image.
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9. If necessary, use the commands available in your 2D image viewer to interact with the ready-made 2D
image.
NOTE: Before creating a 2D image you can choose a viewpoint for the image by navigating in the 3D View
window. But after using the Update 2D Images command (2D Image menu), the 2D image viewpoint
changes to the predefined viewpoint of the IPC page associated with the 2D image for which the image is
created.
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2.5.6

Editing 2D Image

The Edit 2D Images command (2D Image menu > Edit 2D Images) allows deleting unnecessary 2D images,
editing the images name and description, replacing and exporting 2D images that need to be edited using the
external tools and then replacing existing images with their corrected versions.

Procedure
To edit an image name:
1. In the Project images box, select the image name.
2. Click the selected image name to switch to the editing mode.

3. Change the image name and click somewhere in the Project images box to exit the editing mode.
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To edit an image description:
1. In the Project images box, select the image name.
2. In the Image description box, enter the description for the selected image.
To delete a 2D image:


In the Project images box, select the name of image to be deleted, and then click Delete.

To replace a 2D image with another 2D image:
1. In the Project images box, select the name of image to be replaced, and then click Replace.
2. In the Select 2D Image dialog box, select a 2D image for replacement, and then click Open.
To export a 2D image:
1. In the Project images box, select the name of image to be exported, and then click Export.
2. In the Export 2D Image dialog box, select a location for the exported image, and then click Save.
To edit a 2D image in an external editor:
1. In the Project images box, select the name of image to be edited, and then click Edit.
The image will be opened with an external editor that was previously specified in the Options dialog box
(Tools> Options> External Editors > Vector 2D Images or Raster 2D Images). If no external editor is
specified, the built-in Cortona 2D Editor Pro is used as a CGM editor. See the RapidCatalog help system for
more information about choosing an external editor (topic: Choosing an External Editor for 2D Images).
2. Save the edited image and close the external editor.

2.5.7

Attaching 2D Image

A ready-made 2D image (CGM file format) can be attached to any IPC page
(2D Image menu > Attach 2D Image to Current Page).
Procedure
To attach a 2D image to an IPC page:
1. Activate the page for attaching a 2D image to it.
2. On the 2D Image menu, click Attach 2D Image to Current Page.
The Attach 2D Image dialog box appears.
3. In the Attach 2D Image dialog box, select an image file to be attached, and then click Open.
The Edit 2D Images dialog box appears.
4. In the Edit 2D Images dialog box, in the Project image box, change the name of the newly added
image (if necessary) and in the Image description box, enter the image description. See section 2.5.6
for more detailed description of the Edit 2D Image dialog box.
5. Click OK to save the changes and to close the Edit 2D Images dialog box.

2.6

Previewing IPC Publication

At any stage of the editing procedure, the IPC publication can be previewed using the Preview command in
RapidCatalog. The Preview command saves the IPC publication in a temporary folder and opens it in MS
Internet Explorer.
Procedure
To preview the IPC publication:


On the File menu, click Preview.
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2.7

Publishing IPC Publication

Once the editing procedure has been completed and the preview is satisfactory, generate the IPC publication
using the Publish command in RapidCatalog.
NOTE: The appearance and visualization mode of the IPC publication are defined by the specification
component used. The appearance and the mode can be edited using a set of options in the Publish Options
dialog box (Tools > Publish Options). The detailed description of publish options for each specification
component is available by clicking the Help button in the Publish Options dialog box.
See section 3 for more information about specifications. See also section 4.12.3 for creating the IPC
publication in 2D mode.

2.7.1 Validating Project Metadata
Before starting the publish process, check and fill the project metadata. There are mandatory project
metadata whose values must be filled in to ensure that the IPC publication is valid. The metadata can be
edited and added in the Metadata window. See the RapidCatalog help system for more information about the
Metadata window (topic: Metadata Window: Overview).
Procedure
To add/edit project metadata values:


Click any blank space in the 3D View window or Item Tree, and then activate the Metadata window by
clicking it.



In the Metadata window, in the Project category, type a value for the required metadata.



Click somewhere in the window to apply the changes.

NOTE: Mandatory metadata is marked bold. Read-only metadata (marked gray) is data whose values
cannot be edited.

2.7.2 Publish Process
Use the Publish command to generate the IPC publication.
The Publish command:
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Saves the current project.



Validates the current project.



Saves the IPC publication in a folder specified.



Optionally runs the IPC publication.

Procedure
1. On the File menu, click Publish.
2. If some mandatory metadata is missing, a message appears allowing the publish process to be stopped
and the missing mandatory metadata to be filled in in the corresponding editor. Click No to correct the
metadata.
If all mandatory metadata is valid, the Publish Location dialog box appears.
3. If necessary, in the Publish Location dialog box, change the path for the IPC publication, and then
click OK.
After the publish process is completed, the Publish dialog box appears.
The Publish dialog box displays the status of the publish process, size of 3D data in the IPC
publication, total number of faces and representations, and allows the user to immediately run the IPC
publication. Knowing the total number of faces and representations allows the user to estimate the
weight and complexity of 3D data used in the IPC publication: the more faces, the heavier the IPC
publication.

4. Click OK to run the IPC publication.
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3 Working with Specifications
3.1

Specifications: Overview

RapidAuthor uses a set of customizable components (specification components) for authoring the RapidAuthor
publications in accordance with various information standards (for example, ATA iSpec 2200, S1000D Issue
2.3 IPD, S1000D Issue 4.0 IPD).
Each RapidAuthor project contains information about the specification component used for creating or opening
the project. When creating a new project, the user should choose a specification component for the project.
A set of specification components can be extended for each RapidAuthor tool.
RapidCatalog uses the specification components of IPC type (IPC specifications). Currently, RapidCatalog
uses the following IPC specifications: ATA 2200 EIPC, ATA 2200 AIPC, S1000D Issue 2.3 IPD, S1000D Issue
4.0 IPD and Generic IPC. The user can choose a language for the specification.
Each IPC specification is designed for a particular information standard and defines the following:


Set of metadata fields required in accordance with the standard.



Set of declarations which describe the DPL table appearance (for example, set of columns, set of
possible data entries for each column).



Set of additional software components that allow the table authoring in accordance with the
standard.



Set of additional software components that allow publishing the IPC publication in formats required
by the standard or additional formats requested by a customer.



Set of resource files (for example, images, styles, scripts, etc.) that define the appearance and
functionality of the IPC publication.

A project created using one specification can be opened using another specification. But this operation may
result in some data loss. This is true for the projects created by RapidCatalog as well as for the project created
by other RapidAuthor tools.
For example, a project created using Procedure specification (by RapidManual) can be copied and then
opened in RapidCatalog using one of the IPC specifications. This operation will result in loss of procedure data
but 3D data will not be lost and can be reused.

3.2

Changing Specifications

To change the current specification component for a project, use the Open As command (File > Open
Project > Open As button).
NOTE: The name of the current specification is displayed in the status bar.
Use the Open As command:


If the required specification component of the project is not installed on the computer. The
command allows you to open the project using the available specifications.



If the project to be opened is created using another RapidAuthor tool (for example, RapidManual).
This allows reusing the 3D data of the project for creating the IPC publication.



If you want to reuse the data of the project created in accordance with a certain specification for
creating a new project in accordance with another specification.

Procedure
To choose a specification for the existing project:
1. On the File menu, click Open Project.
The Open Project dialog box appears.
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2. In the corresponding boxes, click the name of the working space and the name of the project for which
you want to choose a new specification, and then click Open As.

The Select Specification dialog box appears.
3. Choose the required specification, by clicking its name in the Name column, and then choose a
language for the specification.

4. Click OK to save the choice and close the dialog box.
To choose a specification for a new project:
1. On the File menu, click New Project.
The New Project dialog box appears.
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2. In the Use specification box, choose the required specification by clicking its name in the Name
column, and then choose a language for the specification.
3. Click OK to save the choice and close the dialog box.
For reusing the data of the existing project in order to create a new project with other specification, it is
recommended that the user should create a new working space for such project and use the export-import
procedure for creating a new project as follows:
1. In RapidCatalog, create a new working space for a project created with an IPC specification (Tools >
Select Working Space > New button).
2. Import the project to the newly created working space (Tools > Manage Projects > Import button). It is
supposed that the project was previously exported from RapidCatalog or other RapidAuthor tool.
3. Open the project using the desired specification as described above (File > Open Project > Open As
button).

3.3

Validating Specifications

When opening a project (File > Open Project), RapidCatalog validates the project specification to prove that
the specification meets the required conditions and the project can be successfully opened.
The possible warning messages and recommended actions are described below.


If RapidCatalog detects that the specification for the project is not specified (the Specification field is
empty in the Open Project dialog box), the Select Specification dialog box appears.

Recommended actions: choose the specification from a list of available specifications or
install the required specification, if it is not currently available.


If no IPC specifications (designed to use by RapidCatalog) are installed on the computer, a warning
message appears instead of the Select Specification dialog box:
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Recommended actions: install the required specification component on the computer and try
opening the project once more or use the Open As command to change the specification of
the project.


If RapidCatalog detects that the specification component of the project to be opened is not of IPC type
(the project is created using another RapidAuthor tool), a warning message appears indicating this
situation.
For example:

Recommended actions: try to open the project with the other RapidAuthor tool
(RapidManual/RapidLearning) or use the Open As command for changing the specification.


When opening a project with the Open As command (File > Open Project > Open As button),
RapidCatalog may detect that the project cannot be opened without data loss because the metadata
of two specifications (the current and the newly chosen one) does not coincide. The message appears
indicating that the conflict between two specifications is detected and it can be solved but warns that
this can result in some data loss from the project being opened.
For example:

Recommended actions: Click Yes to continue opening the project, click NO to stop opening
the project.
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After clicking Yes, a message appears showing the problem-solving results and RapidCatalog
goes to the next step of validation.
For example:

Recommended actions: Click OK and the project will be opened.


If the types of the two specifications are incompatible, RapidCatalog removes the incompatible data
from the current specification of the project and a message appears:

Recommended actions: Click OK and the project will be opened.

3.4

Adding Specifications

The Import specification button is used for adding a new specification (in VMS file format) to the list of
available specifications.
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Procedure
To import a new specification:
1. On the File menu, click New Project.
The New Project dialog box appears.
2. In the New Project dialog box, click Import specification.
The Import Specification dialog box appears.
3. Choose the specification file and click Open.
The name of the new specification appears in the Use Specification area of the New Project dialog box.

4 Useful Operations
4.1

Adding Input Data to Existing Project

To add input data to the existing project, follow the procedure below:
Procedure
1. Start RapidGenerator.
2. From the Tools menu, choose Select Working Space.
In the Select Working Space dialog box, click the desired working space, and then click OK.
3. To choose the existing project, from the File menu, click Open Project.
4. In the Open Project dialog box, click the desired project, and then click OK.
5. Choose the RapidDataImportTool plug-in by clicking its name in the Plug-in name box.
6. To choose the import profile, click Settings.
In the Choose profile dialog box, select the required import profile.
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7. In the Choose Profile dialog box, click the name of the required profile. For more information about the
current dialog box, click the Help button.
8. To start importing the input data, click Start.
9. In the dialog box, select the supported geometry file to be imported, and then click Open.
NOTE: The options available in the dialog box depend on the chosen profile. In general, the dialog box
allows you to select 3D data and additional PDM data (optionally).
10. The time required for the import procedure depends on the amount of input data. RapidGenerator saves
the project when the import is finished. If the import setting other than the default ones are used, be
sure to save the project when the import is finished (File menu > Save).

4.2

Additional Optimization of Existing Project

If no suitable representation for significant amount of Items can be chosen from a standard set of
representations automatically generated by RapidGenerator, a new level of detail (LOD) can be added for
each Item of the existing project. To do this, process the project in RapidGenerator with the settings specified
below.
Procedure
To add an additional LOD for all items of the existing project:
1. Start RapidGenerator. Choose the RapidDataImportTool plug-in.
2. Select the working space Tools > Select Working Space.
3. Open the project File > Open Project.
4. Specify the settings for additional optimization. Choose Tools > Options and click the
Representations tab.
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5. In the Representations list, choose the Super quality level, and then click Remove. Repeat this for all
existing levels.
6. Click Add and enter a name for a new level of detail.
7. Select the Quality-based type and enter a reasonable quality value. Click OK.
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8. Click the Optimization tab and in the Optimization of existing projects field, choose Make for all
parts option as shown below.

9. Clear the Allow to replace LODs box and the Set the smallest representation as current box as shown
below.
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10. To use the specified settings for updating the projects later on, save the settings into a file. To do this,
click Save, and then specify a new file name and location.
The saved file includes information about all RapidGenerator settings that can be specified via the
Tools > Options command. The file can be used to restore the specified settings in the future (Choose
Tools > Options and click Load).
11. Click OK to close the Options dialog box.
12. Choose Action > Start Optimization.
13. When the optimization is completed, save the project (File > Save) if the project has not been saved
automatically in accordance with the default value of the Automatically save processed project
setting (Options > General tab > Automatically save processed project).
To restore the default settings:

4.3

1.

Choose Tools > Options, click the Representations tab, and then click Restore Defaults.

2.

Choose Tools > Options, click the Optimization tab, and then click Restore Defaults.

Viewing Discrepancy Log

If the RapidGenerator plug-in imports 3D data and PDM data simultaneously, it automatically links the 3D
data with associated Parts List data and generates the discrepancy log. The discrepancy log is needed to
understand whether the links between the 3D data and Parts List data have been correctly established.
The discrepancy log can be viewed using either RapidGenerator or RapidCatalog.
This functionality can be demonstrated by selecting one of the demo working spaces that contains a readymade RapidAuthor project. Refer to the Installation Instruction document for the particular working space
name.
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Procedure
To view the discrepancy log:
1. Start RapidGenerator or RapidCatalog.
2. On the Tools menu, click Manage Projects.
3. In the Manage Projects dialog box, in the Projects box on the left, click the name of required project.
4. In the Project settings area, click View Working Log.

The discrepancy log appears. Each row of the log marked as “Assembly” or “Part” corresponds to a
DPL table row.
In the discrepancy log, click Legend to open the discrepancy log help system.
5. In the Manage Projects dialog box, click Cancel.
The discrepancy log window remains visible and the information it contains can be used for analyzing
the import results. The window can be closed at any time.
If the links are not established or are established incorrectly, they can be corrected manually by editing the
DPL table (see section 2.2.3 for more information about editing links between DPL rows and Items).
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4.4

Exchanging Projects between Authors

This section describes the mechanism that RapidCatalog and RapidGenerator applications provide for
exchanging data.
Procedure
To export project(s):
1. Start RapidCatalog or RapidGenerator.
2. Select the working space that contains the project(s) to be exported. To do this, click Tools and choose
Select Working Space. In the Select Working Space dialog box, choose the name of working space
by clicking it. Click OK.
3. On the Tools menu, click Manage Projects.
4. Select the project to be exported from the Project box on the left, and then click Export. Please note
that all projects can be selected by clicking Projects.
5. Specify the location where the selected project(s) will be saved in the Save in field.
6. In File name, type a name for the project archive (VMP file), and then click Save.
7. Click OK to close the Manage Projects dialog box.
To import project(s):
1. Start RapidCatalog or RapidGenerator.
2. Select the working space to contain the project(s).
3. On the Tools menu, click Manage Projects.
4. Click Projects in the Project box on the left, and then click Import.
5. In the Import Project dialog box, choose and open the folder containing the project archive (VMP file).
Select the project archive by clicking it, and then click Open.
6. If the project archive contains several projects, the Import Multiple Projects dialog box appears. In the
Projects list, select the project(s) to be imported. Click OK. Please note that, by default, all projects in
the Projects list appear selected.
7. Click OK to close the Manage Projects dialog box.
Authors can also exchange 3D data of the projects.
To export a subset of the project 3D data:
1. Open the desired project in RapidCatalog.
2. Select the Items to be exported in the Item Tree or Item List or 3D View windows.
3. On the File menu, click Export Selection.
4. Specify the location where the selected part of project will be saved in the Save in field.
5. In the File name box, type a name for the part of project archive (VMP file), and then click Save.
NOTE: The archive does not contain DPL table.
To add 3D data to a project from other project archive (VMP file):
1. Open the project in RapidCatalog.
2. Select the working space that you wish to contain the project(s).
3. On the File menu, click Add Project.
4. In the Add Project dialog box, choose and open the folder containing project archive (VMP file). Select
the project archive by clicking it, and then click Open.
5. Save the updated project.
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4.5

Revision Support

RapidCatalog allows tracking changes for the RapidAuthor project during the editing process.
Procedure
To initiate the revision cycle manually:
1. From the File menu, click New Revision.
2. In the Revision Parameters dialog box, type the required data, and then click OK.
Once the revision process has been enabled, all changes made to the project appear marked with a red
revision mark:
IPC Pages
The modified IPC pages appear marked with a revision mark as shown in the figure below.

Any IPC page can be manually marked as New, Revised, Unchanged, Deleted using the context-sensitive
command Revision Status.
Procedure
To mark/unmark IPC pages as revised:


Right-click the page, and then click Revised.

NOTE: In the IPC publication, the R revision mark near the Sheet box indicates the revised pages.
DPL Table
All changes made in the DPL table are marked with a vertical red line as shown in the figure below.

If necessary, the revision mark can be removed.
Procedure
To remove the revision mark:
1. In the DPL table, double-click the cell containing the revised data.
2. Right-click the revised data and then click Remove Revision Mark.

4.6

Editing Reference Tables

The reference tables (Tools > Reference Tables) show a list of reference values and their descriptions. The
table is used for filling in the values of metadata or the parameters of DPL entries in accordance with the
specification (see section 2.2.2 for more information about parameters and values). The reference tables can
be imported and exported in the *.reftbl file format.
Each reference table contains two columns: Value and Description.
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Procedure
To add a new value and its description to the chosen reference table:
1. In the Reference Tables box, click the name of the required reference table.
2. In the Description box, enter the required information.
3. In the Value box, enter the required value.
4. Click Add.

The new value and its description appear in the chosen reference table.
To modify a value or description in the chosen reference table:
1. In the Reference Tables box, click the name of the required reference table.
2. In the reference table, click the entry to be modified.
The value and its description appear in the Value box and in the Description box, respectively.
3. In the Description box, change the information.
4. In the Value box, change the value.
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5. Click Modify.
The value and its description appear changed in the chosen reference table.
To remove an entry from the chosen reference table:
1. In the Reference Tables box, click the name of the required reference table.
2. In the reference table, click the entry to be deleted.
3. Click Delete.

4.7

Specifying Axes for 3D View Window

The axis tripod shows the direction and orientation of 3D model in the 3D View window. The axes required for
the project can be selected from a list of available types or you can add a custom axis tripod.
Procedure
To add an axis tripod:
1. On the Tools menu, click Options, click 3D View, and then choose Axes.
2. In the Axes types area, click Add.
The Add Axes dialog box appears.
3. In the Add Axes dialog box, choose the desired VRML file and click Open.
The name of new axis tripod appears in the list of available axis tripods.
To choose an axis tripod from a list of available tripods:
1. On the Tools menu, click Options, click 3D View, and choose Axes.
2. In the Axes types area, select the desired axis tripod and click Apply in the Options dialog box.
NOTE: Certain specifications limit the axis types available for use and the option to change may not be
available.
To set the position of the chosen axis tripod, in the Position area, enter the required percentage (from 0 to
100) of the 3D View window width and length along the X and Y axes, and then click Apply. The default
coordinate system has origin (0, 0) in the top-left corner of the 3D View window.

4.8

Creating Exploded Views

This section describes how to create an exploded view on an IPC page.
Several steps are required for exploding an assembly:
1. Select Items for exploded view in Item Tree or Item List or 3D View windows.
2. Start Explosion Wizard. To do this on the Edit menu, click Explode Assemblies.
3. Follow the instructions of wizard:

4.8.1 Select Item Collection to Explode
The Select Item Collection to Explode window of the wizard allows creating a new collection or to choose the
existing collection for explosion. A collection is a set of Items that can be subjected to different operations for example, explosion or implosion. A list of available collections is displayed in the Collections window. For
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more information about collections, see the program help system (topics: Editing a Collection, Creating a
Collection and Collections Window: Overview)

Procedure
To create a new collection:
1. Select the Items for the exploded view in the Item Tree or Item List or Thumbnails or 3D View windows.
2. Choose Create new collection and enter a name for a new collection.
or
1. Select the Items for the exploded view in Item Tree or Item List or Thumbnails windows.
2. Drag the selected Items from the windows and drop the Items into an empty space of Select collection
box of the wizard.
To choose an existing collection:


Choose Select collection box and click the desired collection in the corresponding box.

4.8.2 Select Items to Explode
The window appears with a list of selected Items in the Explosion list box. The window allows Items to be
added, replaced, and removed from the explosion list. To remove the Items from the explosion list, select
Item(s) in the Explosion list box, and then click Remove. When the desired Items have been selected, click
Next.
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NOTE: If not all of the desired Items are selected before starting the Explosion Wizard, the Items can be
added one by one to the Explosion list box. To add Item to the Explosion list box, select Item in the Item
Tree, and then click Add.

4.8.3 Set Explosion Type
The next step is to choose the required type of explosion. It is recommended that the linear type of explosion
should be used for disassembling the assemblies consisting of heterogeneous Items. Heterogeneous Items
are Items that differ in size and in form. The radial type of explosion should be used for disassembling the
assemblies consisting of axial-symmetric Items.

Linear explosion explodes the selected Items along the specified axis with the specified strength. The
selected Items are placed equidistantly from each other along the chosen axis (see the figure below).
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Linear explosion along Y-axis

Radial explosion explodes the selected Items away from the specified axis with the specified strength. The
selected Items are placed equidistantly from each other along the line perpendicular to the chosen axis (see
the figure below).

Radial explosion perpendicular to Z-axis
When the type of explosion is chosen, click Next.

4.8.4 Set Direction/Axis and Strength
For radial explosion, the next step is to set axis and strength. For linear explosion, the next step is to set
direction and strength. When either of the windows opens, the manipulator appears in the 3D View window.
The manipulator is a transformation icon that allows Items to be moved quickly along an axis, rotated, or
translated along any two axes simultaneously.
The Set Direction and Strength window is slightly different from the Set Axis and Strength window (see the
RapidCatalog help system for more information about the windows, topics: Step 4: Set Direction and
Strength, Step 4: Set Axis and Strength), but in both windows the axis and strength of explosion should be
chosen.
Procedure
To set the direction/axis for the explosion, do one of the following:


Click one of the axes in the Explosion Wizard window.



Place the mouse pointer over the required axis of the manipulator in the 3D View window. When the
axis turns red, drag it.

To set the strength value of explosion, do one of the following:
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Using the left mouse button, drag the slider until the desired value of strength appears in the Strength
box. The range of strength values depends on the size of explosion Items: the bigger the Items, the
wider the range.



Type the desired value in the Strength box.



Place the mouse pointer over any axis of the manipulator in the 3D View window. This axis turns red
to indicate that it is active. Drag the manipulator along the selected axis. As this is done, a green line
begins to track the axis, showing the distance and direction at which Items will move during the
explosion. Stop dragging the manipulator in the 3D View window, when the required distance is
reached.

Once the strength and direction of the explosion have been set, click Next.

4.8.5 Reorder Items
The next step is to change the sequence of explosion Items.

The Item in bold in the Explosion Items box is a default anchor. The anchor is the basic Item that maintains
its position during explosion. The anchor serves as the epicenter of explosion: during the explosion, all
explosion Items move from the anchor in the specified direction. The default anchor can be changed.
NOTE: The explosion items move from the anchor in the chosen direction, if these items lay in the positive
region of the chosen axis; but the items move opposite the chosen direction, if they lay in the negative region
of the chosen axis.
Procedure
To set Item as the anchor:


Click the desired Item in the Explosion Items box, and then click Set Anchor.
As a result, the explosion Items change their positions relative to the new anchor in the 3D View
window.

Items can be rearranged by moving them up and down in the Explosion Items box.
Procedure
To move Item(s) up or down:


Select the desired Item(s) in the Explosion Items box, and then click Move Up or Move Down.

For better display of some Items (couplings, fittings etc.) within the exploded view, it is necessary to make the
Items equidistant from the anchor. For this effect, group the desired Items together. Groups of Items are
separated from each other by a line of light gray color and are marked by an indent. Items within a group can
be aligned (for more information about the alignment, see the RapidCatalog help system, topic: Aligning
Items within a Group).
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Procedure
To create a group:


Select the desired Items in the Explosion Items box, and click Make Group.

To remove Item(s) from a group:


Select the desired Item(s) in the Explosion Items box, and click Leave Group.

Once the Items have been arranged to satisfaction, click Next.

4.8.6 Reposition Items
The final step is to change the position of Item(s) in the 3D View window.

Each line in the Explosion Items box contains a group of one or more Items. Items within a group are
separated by commas. Only the entire line (group of Items) can be selected. This allows the whole group to
be repositioned at a time. The selected group can be moved in the specified direction using the slider.
Procedure
To change the position of Item(s):
1. Select the required group in the Explosion Items box or in the 3D View window.
2. Then drag the slider, observing the changes in the 3D View window.
Once the Items have been placed to the desired positions, click Finish to complete the explosion.

4.9

Explosion in Two Directions

Sometimes it is required to explode groups of Items within an assembly along different axes. To do this,
during the assembly explosion, group the Items to be exploded in a different direction from the rest Items of
the assembly, and then explode the group of Items separately.
Procedure
To explode Items of an assembly in two different directions:
1. On the active page, delete the Items not required for explosion, and select the Items of the assembly to
be exploded (see Fig. 4).
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Fig. 4
2. From the Edit menu, choose Explode Assemblies. The Explosion Wizard appears.
3. Follow the instructions of the Explosion Wizard. In the Reorder Items window of the Explosion Wizard,
select Items to be exploded in the other direction from the rest Items of the assembly, and then click
Make Group.
4. Finish the explosion. The grouped Items remain unexploded (see Fig. 5).

Fig. 5
5. Select the grouped Items of the exploded assembly, and explode them in the other direction
(see Fig. 6).
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Fig. 6

4.10 Selecting Items
There are several techniques for selecting Items using different selection modes described below.

4.10.1 Selecting Items in Item Tree or Item List
Procedure
To select Item(s) in the Item Tree or Item List windows:


Click the Item name or icon. The name of the selected Item is highlighted.



To select multiple Items, click the Items one by one with the CTRL key pressed.



To select a group of Items that are next to each other, click the first Item, and then click the last Item
with the SHIFT key pressed.



To select Items by a selection rectangle drawn in the Item Tree window, click somewhere in the
window and drag to pull out a selection rectangle. Continue dragging until the rectangle encloses all
required Items.

4.10.2 Selecting Items in 3D View Window
To select Items directly in the 3D View window, on the Selection menu, click Selection in 3D

.

There are two ways for selecting Items in the 3D View window: clicking Item in the 3D View window, or
drawing a selection rectangle (the Frame Selection mode).
These ways are used in the following 3D selection modes:
The Frame Selection Mode provides two selection options: Frame Crossing and Frame Bounding.


Frame Crossing selects those Items that have at least one face inside the selection rectangle
drawn in the 3D View window.



Frame Bounding selects those Items that have all faces inside the rectangle drawn in the 3D View
window.

The
Assembly Selection in 3D mode allows the parent assembly of Item to be selected in the 3D View
window. To enable the mode, on the Selection menu, click Assembly Selection in 3D.
The
Step-by-Step Selection in 3D mode allows the parent Item to be selected by clicking its child Item
in the 3D View window. Clicking successively the child Items navigates up the Item Tree hierarchy until the
last parent Item of the hierarchy is achieved. When the last parent Item of the hierarchy is achieved, the
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selection returns to the Item initially selected in the 3D View window. To enable the mode, on the Selection
menu, click Step-by-Step Selection in 3D.
When the SHIFT, CTRL, or ALT key is pressed simultaneously with selecting Items,
CTRL – adds to the selection,
ALT – subtracts from the selection,
SHIFT – if in the Frame Selection mode, selects from the already selected.
Procedure
To select Item in the 3D View window:


Click the required Item in the 3D View window.
This highlights Item if the Highlight Selection button is pressed.

To select multiple Items in the 3D View window:


Press and hold down CTRL, and then click each required Item in the 3D View window you want to
select.

To select Items by a selection rectangle:
1. Choose one of the available selection options – Frame Crossing or Frame Bounding by choosing the
corresponding command from the Selection menu.
2. Click somewhere in the 3D View window and drag to pull out a selection rectangle. Continue dragging
until the rectangle encloses all Items to be selected. Be sure to start dragging at a point that will enclose
the Items required within a rectangle drawn from that point. Release the mouse button. The Items that
fall inside the selection rectangle appear highlighted.

4.10.3 Selecting Linked Items
The

sphere icon beside a DPL row can be used for selecting linked Items in the 3D View window.

Procedure
To select Item in the 3D View window:


Click the sphere icon beside a DPL row linked to the Item.

To select multiple Items in the 3D View window:


Press and hold down CTRL (a plus sign appears beside the mouse pointer), and then click each
sphere icon of DPL rows linked to the Items.

To subtract some Items from selection:


Press and hold down ALT (a minus sign appears beside the mouse pointer), and then click each
sphere icon of the selected DPL rows linked to the Items.

4.11 Sorting DPL Data
The DPL data can be sorted ascending by any column. The user may change the sort column and direction
by double-clicking the column headings or using the Sort Rows by {name of column} command. This will
cause a
small triangle to appear on the column heading that indicates the sort column and sort direction.
The Auto Sort mode can be used to automatically sort the newly entered data (or changed data) in ascending
order within the chosen column.
If the Sort Rows by {name of column} command is used without Auto Sort enabled, the newly entered data
(or changed data) will not be sorted automatically, but the data order can be changed afterwards by doubleclicking the name of the required column. If the Sort Rows by {name of column} command is used with Auto
Sort enabled, the newly entered data (or changed data) will automatically find its right place.
NOTE:


When saving the project, any sort settings are cleared, but the sort order of rows is saved.



When published, the DPL rows are sorted in accordance with the specification used.
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Procedure
To sort the DPL data by columns:


Right-click the DPL table header, point to Sort Rows by, and then click the required name of the
column.

To automatically sort the DPL data:


Right-click the DPL table header, point to Sort Rows by, and then click Auto Sort.
By default, the Auto Sort command is enabled.

4.12 Recommendations on Increasing IPC Publication Performance
The following are recommendations for increasing the performance of the IPC publication.
For increasing the performance:


Estimate the IPC publication performance by studying the performance related characteristics of the
project.



Optimize 3D data of the project.



Publish IPC publication in 2D mode (if the optimization cannot help).

4.12.1 Estimating IPC Publication Performance
The following characteristics affect the 3D data file size and correspondingly the IPC publication loading time:


Number of unique representations.



Total number of faces.

The following characteristics affect 3D viewer performance that can be measured in fps (frames per second):


Total number of representations.



Total number of faces.

The greater the numbers, the lower the performance.
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4.12.1.1 Project Info Command
The RapidCatalog Project Info dialog box (File menu > Project Info) displays information that allows the
author to estimate the characteristics of each IPC page. These characteristics affect the performance of the
IPC publication.

The following values are important for the performance and the publication size:
Items: the number of Items that have geometric representations in the Base or an IPC page (whichever is
activated).
Unique representations: the number of unique representations used in the Base or an IPC page (whichever
is activated).
Weight (faces): the number of faces used in the Base or an IPC page (whichever is activated).
Procedure
To see the performance related characteristics of the Base or an IPC page:
1. In the IPC pages window, activate (double-click) the IPC page or the Base to be checked.
2. Choose File > Project Info.
4.12.1.2 Publish Command
After the publish process is completed, the message box appears. It displays the performance related
characteristics such as: size of 3D data, total number of faces and representations in the IPC publication.

The information is related to the whole IPC publication. All 3D data that appear in any of IPC page are taken
into account.
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4.12.2 Optimizing 3D Data
4.12.2.1 Remove Unnecessary Items
Reduce the file size by removing hidden parts and small parts, e.g. screws, bolts, rivets etc., from the
background assemblies. As the assemblies are used to help orientate the user, keep only the main items that
will allow the user to recognize the assembly. The unnecessary parts should be deleted in the Base.

Full Assembly

Reduced Assembly
4.12.2.2 Merge Items
The performance of the IPC publication can be increased by merging the background assemblies.
The performance can also be increased by combining multiple Items, which are linked to a single DPL row,
into an assembly and by merging it. This should only be done if all Items are exploded in the same direction.
Procedure
To merge Items which are children of one assembly Item:


Right-click the assembly Item in the Item Tree window and click Merge Assembly.
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4.12.2.3 Create a New Level of Detail
If no appropriate level of detail for 3D data can be chosen from the standard set because one LOD is too
heavy whereas the next smaller LOD is too simplified, a new LOD can be added to the project using
RapidGenerator. See section 4.2 for more information about adding a new level of detail.

4.12.3 Creating IPC Publication in 2D Mode
If the 3D data file size is too large, the IPC publication can be created in 2D mode. When this mode is
chosen, the IPC publication contains only the IPC pages with 2D data, other IPC pages are unavailable.
Procedure
To create the IPC publication in 2D mode:
1. On the Tools menu, click Publish Options.
The Publish Options dialog box appears.
2. Double-click the Value field of the Illustration Type option to enter the editing mode.

3. On the list of available values, click 2D only.

4. Click somewhere in the dialog box to exit the editing mode.
5. Click OK to apply the changes and to close the dialog box.
6. On the File menu, click Publish.
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